DNSChain Help

okTurtles Forums DNSChain DNSChain Help

This topic contains 8 replies, has 2 voices, and was last updated by  greg 4 years, 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #700

    Hi All,

    First time user here,  I am installing this on Windows Azure using ubuntu and when I try to run I am getting the following error, any ideas?

    [NMC] connected to namecoind: 127.0.0.1:8336
    2014-09-30T15:45:04.210Z – info: [DNS] started DNS
    { port: 5333,
      host: '0.0.0.0',
      externalIP: 'xx.102.xxx.75',
      oldDNSMethod: 0,
      oldDNS:
      { address: '8.8.8.8',
        port: 53,
        type: 'udp' } }
    2014-09-30T15:45:04.218Z – info: [HTTP] started HTTP
    { port: 8088,
      tlsPort: 4443,
      host: '0.0.0.0' }
    2014-09-30T15:45:04.219Z – info: [DNSChain] DNSChain started and advertising on: xx.102.xxx.75
    2014-09-30T15:45:04.224Z – warn: [DNSChain] DNS port isn't 53! While testing you should either run me as root or make sure to set standard ports in the configuration!

    • This topic was modified 9 months, 1 week ago by  greg. Reason: Moved to DNSChain forum
    #864

    greg
    Keymaster

    Hey crazyitalian,

    That's a warning, and it telling you that in order to bind to port 53 it needs root/admin privileges. Since it doesn't have them it chose to bind to port 5333 which doesn't require admin privs.

    #865

    Hey crazyitalian,

    That's a warning, and it telling you that in order to bind to port 53 it needs root/admin privileges. Since it doesn't have them it chose to bind to port 5333 which doesn't require admin privs.

    Howdy Greg,

    Thanks for the input, does this mean it is running?  How would I go about testing?

    #866

    greg
    Keymaster

    Yeah, it's running. If you have it running locally and on port 53, you can set your DNS to localhost (127.0.0.1) and visit okturtles.bit or namecoin.dns/d/okturtles.

    If it's on port 5333, then you can test with a command like dig on linux (or on windows, via cygwin or other unix-like environment):

    If you want to keep it running on port 5333, use dig like so:

    Code:
    -> % dig localhost -p 5333 okturtles.bit

    ; < <>> DiG 9.8.3-P1 < <>> localhost -p 5333 okturtles.bit
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER< <- opcode: QUERY, status: NOERROR, id: 54155
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;localhost. IN A

    ;; ANSWER SECTION:
    localhost. 86400 IN A 127.0.0.1

    ;; Query time: 63 msec
    ;; SERVER: 127.0.0.1#5333(127.0.0.1)
    ;; WHEN: Tue Sep 30 13:31:48 2014
    ;; MSG SIZE  rcvd: 43

    ;; Got answer:
    ;; ->>HEADER< <- opcode: QUERY, status: NOERROR, id: 918
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;okturtles.bit. IN A

    ;; ANSWER SECTION:
    okturtles.bit. 600 IN A 192.184.93.146

    ;; Query time: 59 msec
    ;; SERVER: 127.0.0.1#5333(127.0.0.1)
    ;; WHEN: Tue Sep 30 13:31:48 2014
    ;; MSG SIZE  rcvd: 47

    #867

    I actually have it running on a remote server, would I just replace the localhost IP with the remote one?

    #868

    Running it yields the following results:

    Last login: Tue Sep 30 15:01:40 on ttys000
    Roberts-MacBook-Pro:~ robertdejesus$ dig localhost -p 5333 okturtles.bit
    ^CRoberts-MacBook-Pro:~ robertdejesus$ dig 10.102.144.75 -p 5333 okturtles.bit

    ; < <>> DiG 9.8.3-P1 < <>> 10.102.144.75 -p 5333 okturtles.bit
    ;; global options: +cmd
    ;; connection timed out; no servers could be reached
    ;; connection timed out; no servers could be reached
    Roberts-MacBook-Pro:~ robertdejesus$

    #869

    greg
    Keymaster

    If it's running on a remote server then you need to make sure the port that it's running on is forwarded. You can do that by installing and setting up a package like ufw. Then you'd need to query it on its IP, not localhost. And if you want it to serve DNS to other computers, you'll need to either port map port 5333 to 53, or run it as root (not recommended) so that it can run on 53 directly.

    For remote computers, you should also use systemd, and then run DNSChain via the included systemd unit file. Note that we've setup that file to do the port forwarding for you.

    If you don't know what I'm talking about… I recommend doing some research on systemd and linux server admin. Feel free to post dnschain-specific questions here, and if you have general linux/debian questions, StackOverflow, Server Fault, or Ask Ubuntu might be a better places for that.

    #870

    Thanks a ton. 

    #871

    greg
    Keymaster

    no prob! And it's also recommended to pair DNSChain with a traditional resolver like PowerDNS.

    There are some “bare bones” instructions on how to do that in this thread (in the first post).

    Maybe someone will make a nice tutorial on how to do that at some point. 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.